Quản Trị  Thiết Bị Mạng Doanh Nghiệp
 
Từng Bước Cấu Hình Router Cisco
22:17 | 20/05/2010
Thiết bị router Cisco hiện nay cũng đã rất phổ biến. Xin giới thiệu với các bạn một bài LAB hay trong mô hình network system có sử dụng Router Cisco làm định tuyến hệ thống. Các bước cấu hình đường internet ADSL qua router cisco, và xử lý các vấn đề về Wlan, VLAN. Đối với các bạn có nhu cầu thì đây là một file rất hữu ích, chúc các bạn thành công và tự tin trong công việc.





Các bước cấu hình đường internet ADSL qua router cisco

1.version 12.3
2. no service pad
3. service tcp-keepalives-in
4. service tcp-keepalives-out
5. service timestamps debug datetime msec localtime show-timezone
6. service timestamps log datetime msec localtime show-timezone
7. service password-encryption
8. service sequence-numbers
9. !
10. hostname adsl-router
11. !
12. boot-start-marker
13. boot-end-marker
14. !
15. logging buffered 16256 debugging
16. logging rate-limit 15
17. enable secret 5 xxx
18. !
19. clock timezone GMT 0
20. clock summer-time BST recurring 3 Sat Mar 1:00 last Sun Oct 2:00 //set current time
21. no aaa new-model
22. !
23. !
24. ip subnet-zero
25. no ip source-route
26. ip cef
27. !
28. !

// Configure DHCP server intergrated in this router, if not have to configure on Server.

ip subnet-zero
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.10 // no using this group
!
ip dhcp pool VieTechno
import all
network 192.168.1.0 255.255.255.0 // Choose class C to use Locally
dns-server 203.113.131.1 203.113.188.1 // IP DNS server
default-router 203.113.131.1 // default routing to DNS server
lease infinite
!
!
ip name-server 203.113.131.1
ip name-server 203.131.188.1
ip name-server 203.113.131.2
!
!

29. !
30. !
31. no ip bootp server
32. !
33. !
34. interface ATM0/0 // this is the physical WAN interface
35. no ip address
36. no ip redirects
37. no ip unreachables
38. no ip proxy-arp
39. no ip mroute-cache
40. no atm ilmi-keepalive
41. dsl operating-mode auto
42. pvc 0/38 // set VCI/VPI following internet service provider
43. encapsulation aal5mux ppp dialer
44. dialer pool-member 1
45. !
46. !
47. !
48. interface FastEthernet0/0 // port ethernet on router cisco what connected to Switch.
49. description LAN
50. ip address 192.168.1.1 255.255.255.0 // IP local
51. speed 100
52. full-duplex
53. ip nat inside
54. !
55. interface Dialer1 // viturtal Interface WAN
56. description WIC1-ADSL Dialer to Vietechno company
57. ip address negotiated
58. no ip redirects
59. no ip unreachables
60. no ip proxy-arp
61. ip nat outside
62. encapsulation ppp
63. dialer pool 1
64. dialer idle-timeout 0
65. no cdp enable
66. ppp chap hostname zenxxx@zen // input usename from ISP supply to you
67. ppp chap password 7 xxx // input Password from ISP supply to you
68. ppp pap sent-username zenxxx@zen password 7 xxx // input again both
69. ppp ipcp dns request
70. ppp ipcp route default
71. ppp ipcp address accept
72.
73. !
74. !
75. !
76. ip nat inside source list 1 interface Dialer1 overload // NAT from inside to outside
77. no ip http server
78. no ip http secure-server
79. ip classless
80. !
81. !
82. !
83. !
84. access-list 1 permit 192.168.1.0 0.0.0.255 // using wildcast mask ( don’t care, opposite with subnet mask )
85. !
86. !
87. !
88. !
89. !
90. !
91. !
92. line con 0
93. line aux 0
94. line vty 0 4
95. !
96. !
97. end



Cấu Hình Router Kết Nối Với Access Point Có Chia VLAN Cho Các SSID Tương Ứng



1. Cấu hình địa chỉ IP trên interface W1/0 của Router 2811

c2811#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
c2811(config)#
c2811(config)#interface wlan-controller 1/0
c2811(config-if)#ip address 192.168.99.254 255.255.255.0
c2811(config-if)#no shut
c2811(config-if)#end

2. Truy cập vào WLC module từ Router 2811
c2811#service-module wlan-controller 1/0 session
Trying 192.168.99.254, 2066 ... Open

3. Cấu hình WLC từ chế độ SETUP MODE như sau
Cisco Controller
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): cisco
Enter Administrative Password (24 characters max): cisco

Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24

AP Manager Interface IP Address: 192.168.99.25

AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24

Virtual Gateway IP Address: 1.1.1.1

Mobility/RF Group Name: mg1

Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter Country Code (enter 'help' for a list of countries) [US]: US

Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

4. Sau khi khởi động lại WLC
a. Sau khi WLC khởi động xong, truy cập vào WLC từ Router 2811, nhập username cisco và password cisco để vào WLC
b. Để quay trở lại router 2811, nhấn tổ hợp phím ctrl+shift+6 thả ra và nhấn tiếp phím x
c. Kiểm tra đảm bảo Router có thể ping thấy WLC module
c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811#service-module wlan-controller 1/0 session
Trying 192.168.99.254, 2066 ... Open

5. Tạo 2 SSID là: SSID1 và SSID2 trên WLC
Tạo 2 dynamic interface tên vl15 thuộc VLAN 15 và vl16 thuộc VLAN 16
(Cisco Controller) >config interface create vl15 15
(Cisco Controller) >config interface create vl16 16
Gán địa chỉ IP, subnetmask và default gateway cho 2 dynamic interface này
(Cisco Controller) >config interface address vl15
192.168.15.254 255.255.255.0 192.168.15.1

(Cisco Controller) >config interface address vl16
192.168.16.254 255.255.255.0 192.168.16.1
Chú ý: default gateway (192.168.15.1 và 192.168.16.1) cho 2 dynamic interface này chính là địa chỉ ip trên subinterface của router tương ứng với VLAN 15, VLAN16, sẽ được cấu hình ở bước sau
Tạo 2 WLAN 15 và 16 tương ứng với SSIDs wl15 and wl16.
(Cisco Controller) >wlan create 15 wl15
(Cisco Controller) >wlan create 16 wl16
Kết hợp 2 WLAN này với 2 dynamic interface vừa tạo ở trên
(Cisco Controller) >wlan interface 15 vl15
(Cisco Controller) >wlan interface 16 vl16
Vì chúng ta sẽ cấu hình DHCP Server trên Router 2811, nên cấu hình địa chỉ IP của DHCP server cho các WLAN w115 và w116 chỉ đến các subinterface của router 2811 với VLAN tương ứng, nếu trong mạng đã có DHCP server thì ta chỉ đến địa chỉ IP của DHCP server đó
(Cisco Controller) >interface dhcp vl15 192.168.15.1
(Cisco Controller) >interface dhcp vl16 192.168.16.1
Mặc định, tính năng chứng thực dot1X được bật, để chứng thực kiểu open, ta tắt chứng thực dot1X trên 2 WLAN này
(Cisco Controller) >wlan security 802.1X disable 15
(Cisco Controller) >wlan security 802.1X disable 16

6. Cấu hình trên router 2811:
- Cấu hình interface f0/0 trên router 2811 kết nối đến LAP
- Cấu hình interface wlan-controller 1/0 với địa chỉ IP thuộc subnet 192.168.99.0/24, hai subinterface w1/0.15 thuộc VLAN 15 và w1/0.16 thuộc VLAN 16 với các subnet lần lượt là: 192.168.15.0/24 và 192.168.16.0/24
- Cấu hình DHCP server trên router 2811 với 3 pool
o Pool lwapp-ap gán IP cho AP từ subnet 192.168.100.0/24, đông thời bao gồm DHCP option 43 là địa chỉ IP của WLC
o Pool client-15 gán địa chỉ IP cho client (có dây và không dây) thuộc VLAN 15 với subnet 192.168.15.0/24
o Pool client-16 gán địa chỉ IP cho client (có dây và không dây) thuộc VLAN 16 với subnet 192.168.16.0/24
o Cấu hình mẫu trên router thỏa mản các yêu cầu trên như sau:
Router
!
interface FastEthernet0/0
Description: Connected to AP
ip address 192.168.100.1 255.255.255.0
!
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
option 43 HEX f104C0A86318
!--- “f1” la CODE, “04” chi sau do co 4 Byte, “C0A86318” la !dia chi IP cua WLC 192.168.99.24 duoc ghi o dang HEX ---
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1
!
interface wlan-controller1/0
ip address 192.168.99.254 255.255.255.0
!
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.

encapsulation Dot1q 15
ip address 192.168.15.1 255.255.255.0
!
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.

encapsulation Dot1q 16
ip address 192.168.16.1 255.255.255.0
!



Hai bài LAB trên giải quyết khá nhiều vấn đề liên quan đến kỹ thuật quản trị, các thắc mắc chung các bạn gửi mail trực tiếp cho mình.

Nguyễn Thượng Triều.
 
Ý kiến phản hồi và bình luận Góp ý kiến của bạn

Cấu hình Router Cisco

quá hay và đầy đủ - hy vọng sẽ nhận được bài hướng dẫn chi tiết như vậy với các dòng switch layer 3 của Cisco

(Nguyễn Văn Trung)
Các tin mới nhất :
- Thay đổi lưu lượng traffic qua chế độ ưu tiên với DD-WRT
- Cấu hình IP SLA (IP Service Layer Aggrement).
- Cấu hình HSRP
- Quản lý bandwidth của o2security
- Cấu hình SifoWorks UTM phòng chống Mail Spam/Virus
- Cấu hình Juniper SSG
- Cơ bản về cấu hình Vyatta box
- Thiết lập VPN trên Cisco 2600
- Tìm hiểu phương pháp triển khai hệ thống Mail Server của Microsoft cho nhân viên
- Giải pháp Load Balancing Multi-WAN dùng Radware LinkProof (Phần 2)
Các tin liên quan :
Bài nhiều người đọc cùng chuyên mục
Cấu hình HSRP
 
Cấu hình Juniper SSG
 
Tìm hiểu phương pháp triển khai hệ thống Mail Server của Microsoft cho nhân viên
 
Thiết lập VPN trên Cisco 2600
 
Cơ bản về cấu hình Vyatta box
 
Backup và Restore Router Cisco
 
Cấu hình IP SLA (IP Service Layer Aggrement).
 
Trang chủ | Giới thiệu | Quảng cáo | Liên hệ
Giấy phép ICP số 199/GP-TTĐT. Bộ Thông tin và Truyền thông cấp.
Cơ quan quản lý  : Công Ty Cổ Phần Kênh Giải Pháp
Bản quyền © 2010-2011 Kenhgiaiphap.vn . Giữ toàn quyền.
Ghi rõ nguồn "Kenhgiaiphap.vn" khi phát hành lại thông tin từ website này.